Copy paste bug

Copy any item field:
select the first option "Tab indented outline"
create new item
press F2 in the item field
paste
it pastes with a bullet:
if you press return to confirm, you get just the text <UL></UL> in the field - if you try to edit it show a placeholder for an image that it cannot find
if you delete the bullet but leave the text - then press return, everything disappears

Workaround:
simply paste - dont press F2 first

Re: Copy paste bug

Ah, you must be using the new WYSIWYG editor... I did not think of this paste situation.
I'll fix it ASAP
 
In the meantime, you can turn off the WYSIWYG editor... 
 

Re: Copy paste bug


Pierre_Admin wrote:

Ah, you must be using the new WYSIWYG editor... I did not think of this paste situation.
I'll fix it ASAP
 
In the meantime, you can turn off the WYSIWYG editor... 

I forgot to mention it - yes, I use the WYSIWYG

But as said above:
Workaround [for new items]:
simply paste - dont press F2 first
 
 
[Edit in square brackets]

Re: Copy paste bug

I have a problem with pasting after pressing F2, and I'm not using the WYSIWYG editor.
Basically, I can't paste while in edit mode.
 
It could be a problem on my side --  I thought it was since I haven,t got the time to think about it --, but only IQ has that paste bug.
 
Workaround : use shift+F2  to paste in the floating edit box. (The other workaround Tom suggested works too, but isn't always possible/convenient when one is pasting stuff at the end or in the middle of preexisting data.)
 
 
-------------------------------------------------------
Windows 8.1
Sony Vaio S Series 13 (SVS131E21L)
Ram:8gb, CPU: Intel i5-3230M, 2.6ghz

Re: Copy paste bug

Armando wrote:
I have a problem with pasting after pressing F2, and I'm not using the WYSIWYG editor.
Basically, I can't paste while in edit mode.
 
Confirmed and fixed in v0.9.26PreRel40
 

Re: Copy paste bug

 Confirmed and fixed in v0.9.26PreRel40
 

Re: Copy paste bug


Tom wrote:

Copy any item field:

select the first option "Tab indented outline"
create new item
press F2 in the item field
paste
it pastes with a bullet:
if you press return to confirm, you get just the text <UL></UL> in the field - if you try to edit it show a placeholder for an image that it cannot find
if you delete the bullet but leave the text - then press return, everything disappears

I'm afraid this is not fixed Pierre
reproduced in clean 'install' with sample database (with content).
 
Doesnt work either with items with content (pasting 'normal' text works when editing an item).
(As said above, workaround with new item is to simply paste - dont use F2)
_______________________________________________________
Win.7 64bit  ~  IQ 0.9.26Pre-Rel40

Re: Copy paste bug

Here, copy paste is fixed. Using it either with or without WYSIWYG.
I tried your steps, but I'm always  pasting correctly.
 
-------------------------------------------------------
Windows 8.1
Sony Vaio S Series 13 (SVS131E21L)
Ram:8gb, CPU: Intel i5-3230M, 2.6ghz

Re: Copy paste bug

 Apologies, the previous post was using windows 8.1 (I see Armando no longer has the problem on 8.1...)

I restarted IQ with the same file, and it was very contrary, initially no shortcuts worked (no Ctrl+C for copy).
It is now sort-of working - I can paste in the Item field correctly when it's in edit mode - but nothing pastes if it is not in edit mode.
Gotta go now - I'll check it on 8.1 again Monday evening and report back
_______________________________________________________
Win.8.1 64bit  ~  IQ 0.9.26Pre-Rel40
_______________________________________________________________
 
 
In Windows 7, it was initially acting up - nothing seemed to be pasting - I came back after writing here a bit and it had pasted.
Now it appears to be working fine on 7
_______________________________________________________
Win.7 64bit  ~  IQ 0.9.26Pre-Rel40

Re: Copy paste bug

Strange. Keep us posted!
 
-------------------------------------------------------
Windows 8.1
Sony Vaio S Series 13 (SVS131E21L)
Ram:8gb, CPU: Intel i5-3230M, 2.6ghz

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.