HTML unicode references appear in cell after editing with popup editor [details below]

If I'm not editing in WYSIWYG, the HTML unicode references will appear in the cell after editing with the  popup editor (Shift+F2)
 
Work aound : 1-turn on WYSIWYG for the field in the grid, 2-F2 to edit, 3-and then turn WYSIWYG off. HTML Unicode references seem to be reconverted in the process (?).
 

Re: HTML unicode references appear in cell after editing ...

euh... screenshot please...
 

Re: HTML unicode references appear in cell after editing ...

Sure
it's pretty obvious with a simple test.
 
My cell (item field) during NON-WYSIWYG edition, **before** using the popup editor
 
 
 
My cell while being edited with the popup editor
 
 

 
My cell after edition with the popup editor, and WHILE using the NON-WYSIWYG edition
 
 

 
See the funny HTML unicode references in there ? It doesn't go away, unless you turn on WYSIWYG for the column and re-turn it off after pressing F2 for edition.  The cell will then display the characters "normally" (no HTML Unicode references)
 
 
-------------------------------------------------------
Windows 8.1
Sony Vaio S Series 13 (SVS131E21L)
Ram:8gb, CPU: Intel i5-3230M, 2.6ghz

Re: HTML unicode references appear in cell after editing ...

Were you able to reproduce the issue?
-------------------------------------------------------
Windows 8.1
Sony Vaio S Series 13 (SVS131E21L)
Ram:8gb, CPU: Intel i5-3230M, 2.6ghz

Re: HTML unicode references appear in cell after editing ...

No I was not able. I'll release v0.9.26PreRel48 and check it again
 

Re: HTML unicode references appear in cell after editing ...

I'm not getting the same codes (must be related to "default" encoding), but did manage to get " instead of a quote.
Fixed in v0.9.26PreRel49
 

Re: HTML unicode references appear in cell after editing ...

Pierre_Admin wrote:
I'm not getting the same codes (must be related to "default" encoding), but did manage to get " instead of a quote.
Fixed in v0.9.26PreRel49
 
The code in the example above correponds to " ' ", but the French one (curved) : " ’ "
 
-------------------------------------------------------
Windows 8.1
Sony Vaio S Series 13 (SVS131E21L)
Ram:8gb, CPU: Intel i5-3230M, 2.6ghz

Re: HTML unicode references appear in cell after editing ...

OK, thanks for the info. No more mystery then... 

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.