Restore previous layout broken here in pre-rel 29/a

hi Pierre,
restore previous layout no longer working here in pre-release 29 & 29a
 
I always get the message:
 
Restore previous layout...
no previous layout to restore
 
Window 7 x64

Re: Restore previous layout broken here in pre-rel 29/a

Seems to work here. Are you jealous ? 
(I'm still on v29. I know there's a nasty checkbox bug, but I don't use these.)
 
Is it after a crash ? after closing it normally with all your grids opened ? after closing all grids before closing the program ?
 
-------------------------------------------------------
Windows 8.1
Sony Vaio S Series 13 (SVS131E21L)
Ram:8gb, CPU: Intel i5-3230M, 2.6ghz

Re: Restore previous layout broken here in pre-rel 29/a

Armando wrote:
Seems to work here. Are you jealous ? 
very
 
> Is it after a crash ?
No
 
> after closing it normally with all your grids opened ?
Yes.
Reproduced repeatedly with two different files.
 
> after closing all grids before closing the program?
No.
I always left grids open on closing of file.
 

Re: Restore previous layout broken here in pre-rel 29/a

  1. Are you using MDI or tabbed workspace ?
  2. ScreenShot perhaps...
  3. Does it happen with a new sample IQBase?

Re: Restore previous layout broken here in pre-rel 29/a

I get same results with a clean portable 'install' and new sample file - see #3 below.

Pierre_Admin wrote:

  1. Are you using MDI or tabbed workspace ?
  2. ScreenShot perhaps...
  3. Does it happen with a new sample IQBase?

1) not sure what MDI is but I used tabbed. I often use dual pane - sometimes with the calendar on one side
 
2) I took this shot on reopening the file
 
 
 
3)
OK, I just tried this:
unpacked portable IQ 29a to a new folder - no options changed
created a fully new sample file (with content)
opened a couple of grids
closed & reopened the file
exactly the same result
 
 
___________________
Win7 x64

Re: Restore previous layout broken here in pre-rel 29/a

Hi Tom,
 
No idea of what could be doing that.
I upgraded to 29a and it's still working fine here.
 
Did you change some grid names recently ? Did you work with a grid you usually don't use ? Hypothesis : Maybe a specific grid name is generating an error ?
Did you move your DB to some other location ? Not that I think it would make a difference...
 
[EDIT : What's MDI ? Multiple Document Interface. See Tools->Options->General->Use Workspace Tabs. If you uncheck this, IQ will switch to MDI mode]
 
-------------------------------------------------------
Windows 8.1
Sony Vaio S Series 13 (SVS131E21L)
Ram:8gb, CPU: Intel i5-3230M, 2.6ghz

Re: Restore previous layout broken here in pre-rel 29/a

 
 Hi Armando,
did you test it on Windows7? See my post (quoted below) it also happens with a fresh install:
 
Tom wrote:

unpacked portable IQ 29a to a new folder - no options changed
created a fully new sample file (with content)
opened a couple of grids
closed & reopened the file
exactly the same result [i.e. no previous layout found - see screenshot in my previous post]
 
___________________
Win7 x64

Re: Restore previous layout broken here in pre-rel 29/a

Perhaps a regional setting issue...
What are yours ?
Can you try using USA ?
 
Thanks !
 

Re: Restore previous layout broken here in pre-rel 29/a

Pierre_Admin wrote:
Perhaps a regional setting issue...
What are yours ?
Can you try using USA ? 
 
Hi Pierre
will check tomorrow **
and try with US settings (I presume then it's working for someone out there on Windows 7?)
 
 
** posting from Windows 8.1, where I can confirm it's working as expected (with installed version of IQ).
 

Re: Restore previous layout broken here in pre-rel 29/a


Pierre_Admin wrote:

Perhaps a regional setting issue...
What are yours ?
Can you try using USA ? 

Regional settings were:
English (Ireland)
- with a custom date YYYY-MM-DD
 
I changed to
English (US)
and restarted IQ a couple of times - no change, problem still exists.
 
Does restore-previous-layout work for anyone out there using IQ on Windows 7 (x64) ?
or is it just lill ol me?
 
_________________
portable IQ - pre-rel 29a, Win 7 x64

Re: Restore previous layout broken here in pre-rel 29/a

I tested it on a Windows laptop and, yes I'm getting the same as you : "No previous Layout to Restore"
Windows 7 32 bit, regional settings : Canada (French)
I won't be able to do more testing today...
-------------------------------------------------------
Windows 8.1
Sony Vaio S Series 13 (SVS131E21L)
Ram:8gb, CPU: Intel i5-3230M, 2.6ghz

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.