Missing cursor when editing items

When I click on a grid item to start editing, the cursor should appear in the item to mark where the editing will begin.  However, this only happens about 30% of the time.  Most of the time, no cursor appears.  The item is properly selected and I can start editing, but I don't know exactly where I'm at until the letters start appearing in the item.
 
I've tried over and over again to figure out why the cursor appears sometimes but not others.  I haven't been able to figure out a pattern or anything I'm doing differently to make it work one time and not the next. 
 
Wayne
Win 7, 64 bit

Re: Missing cursor when editing items

I've heard only one other user with this issue. I really wonder what could it be.
It never happens to me in grids, but it does happen in the Add item dialog (ctrl+n / Win+n), sometimes.
 
-------------------------------------------------------
Windows 8.1
Sony Vaio S Series 13 (SVS131E21L)
Ram:8gb, CPU: Intel i5-3230M, 2.6ghz

Re: Missing cursor when editing items

Yup, that was me. For your reference the discussion is here.
 
Jon

Re: Missing cursor when editing items

Thanks for the link.  I did a search for "cursor"  but it brought up many unrelated threads.  Yes, this is the same issue except mine also occurs when I edit an existing item.

Re: Missing cursor when editing items

By the way, I continue to have this problem. I cannot see the cursor when I click to edit an item. This happens frequently, but not all the time.
 
Jon

Re: Missing cursor when editing items

Users with this issue :
Does this issue occur on both installed and portable flavors of IQ ?
 
 

Re: Missing cursor when editing items

I switched to the portable version and it appears to have fixed the problem.

Re: Missing cursor when editing items

Not here. I use the portable version exclusively. The issue is now constant. I have observed that if I have word wrap on then create a new item, the cursor is not visible until the item scrolls to the second line. I've been working for over an hour and it happens every time. I never noticed this before and for all I know it will be different when I restart IQ tomorrow.

Re: Missing cursor when editing items

Jon,
 
Do you have many utility programs installed ? Perhaps you can try to uninstall some... Example of some similar issues found on the web:

 
HTH !
 
Pierre_Admin
 

Re: Missing cursor when editing items

Pierre_Admin wrote:
Do you have many utility programs installed ? Perhaps you can try to uninstall some... Example of some similar issues found on the web:

 
 
Interesting, especially because I have a wireless configuration utility running. Although not the same program cited in the discussion, I disabled it. Unfortunately, the problem with the cursor (actually the discussion correctly pointed out that this is an insertion caret, not a cursor) remains. This is the only utility that loads on start. On the off chance that another program might interfere with IQ's caret display, I rebooted Windows and ran IQ as the lone program. Same thing.
 
My thought is that the problem is with IQ. I do not understand why I cannot see the caret when typing into a new item only for it to appear when the entry scrolls to the second line. If another program was interfering, wouldn't the caret never display?
 
Jon

Re: Missing cursor when editing items

I have the problem of cursor disappearance in the add-item dialog, in Windows XP, Windows 8 + Windows 8 SP1. In the HTML pane, it's a lesser evil though.
 
-------------------------------------------------------
Windows 8.1
Sony Vaio S Series 13 (SVS131E21L)
Ram:8gb, CPU: Intel i5-3230M, 2.6ghz

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.